The Novel Factory Community Forum
Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
JunoApollo

Member
Registered:
Posts: 39
Reply with quote  #1 
Hi guys,

This might not even have anything to do with W10, so apologies to MS in advance, but I've had The Novel Factory running on my laptop for well over a year now, and in less than that time I've upgraded my system to Windows 10. Everything has been fine until tonight when I went to open the NF program and.... nothing... no error messages, literally nothing.

I can't open it from the task bar, the shortcut on the desk top, and not even from the actual program icon. I've also tried opening it from the saved files that are my actual novel. But nothing happens. My laptop just sighs silently and flips me the bird.

I have tried a troubleshoot which tells me that the version of the Novel Factory is for Windows 8, but then why has it worked for so long on W10? Also, I tried uninstalling and reinstalling, as well as rebooting the laptop, but nothing. 

Any and all suggestions are more than welcome. FYI, it's after 11 at night here, and I've work in the morning, so I might not reply to any responses tonight, but please do still send them anyways as they are much appreciated.

Thank you!
0
thenovelfactory

Avatar / Picture

Moderator
Registered:
Posts: 270
Reply with quote  #2 

Hi JunoApollo,

If it was previously running OK in Windows 10, it shouldn't be a compatibility issue, although it's possible a recent Windows update may have changed something.  Have you installed the latest version of the software (1.26)?  That version should definitely be Windows 10 compatible, because it was built in Windows 10.  You can get that from the link below:

https://www.novel-software.com/downloads/version_1/novelfactoryinstaller.msi

If the program is still failing to open, there might be a clue in the event viewer.  If you type "Event Viewer" in the windows search bar, you should be able to open it there (it's also on control panel under 'administrative tools').  In the side column, go to Windows Logs > Application.  This should give a list of errors and events logged by Windows.  If you see an error or warning with the same date and time that you tried to open The Novel Factory, have a look at the error message.  If it mentions The Novel Factory or "Novfac", it's probably related, so if you send us that information we might be able to find the problem.

Finally, did you recently install anything such as anti-virus that might interfere with the running of other programs?  The Novel Factory does connect to the internet to get licensing or trial info from our server, and overzealous anti-virus or firewall software may decide to stop it running for that reason, unless an exception is made.

__________________
http://www.novel-software.com
“It's extremely useful in organizing and making me think about what I write. The advice was invaluable, and the step-by-step instructions guided me extremely well through the writing process, allowing me to develop characters and plot a lot further than expected.” - See more at: http://www.novel-software.com/writingsoftwaretestimonials.aspx#sthash.0smYiFBM.dpuf
0
JunoApollo

Member
Registered:
Posts: 39
Reply with quote  #3 
Hi there, thanks for the reply.

I've uninstalled and reinstalled a couple of times just to be sure, and still nothing. I tried the event viewer too, and there's a LOT on it, but nothing that is specific to Novel Factory. I haven't installed anything new lately either, so I'm now beginning to think that it's my laptop. Though I've run both virus scans and performance tests and they've come up clear.

The good news is that I can access everything just fine on my partner's PC, but I'd really prefer to be able to use my own laptop :/ 
0
JunoApollo

Member
Registered:
Posts: 39
Reply with quote  #4 
Ok, so I've spent hours trying to sort this out, even downloading a PC repair tool that didn't work, but I've finally found a workable solution.

I've downloaded The Novel Factory software to my OneDrive and it can be opened from there. It's obviously a problem with my laptop, but no amount of scans will detect anything wrong. This is the best solution, and I'm happy enough. At least the problem isn't with TNF [smile]

Thanks [smile]
0
UncleClover

Avatar / Picture

Junior Member
Registered:
Posts: 1
Reply with quote  #5 

Hi there! I am now having this exact same issue on version 1.33. The latest Windows update seems to have rendered it unusable on this computer - it was working just fine _immediately_ prior to restarting the computer to let the updates take effect. But thankfully, the solution to upload the program folder to the cloud and run it from there actually works. I did manage to get some data from the Event Viewer, here it is if it will help - I'd rather be able to run it on my computer, itself, if possible. I hope this data helps, if there's any other data I can provide just ask. Thanks!

Sincerely,
Wm. D. Shroyer

Data from "Event Viewer":

Application: NovelFactory.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.Xml.XmlException
at System.Xml.XmlTextReaderImpl.Throw(System.Exception)
at System.Xml.XmlTextReaderImpl.Throw(System.String, System.String[])
at System.Xml.XmlTextReaderImpl.ParseText(Int32 ByRef, Int32 ByRef, Int32 ByRef)
at System.Xml.XmlTextReaderImpl.ParseText()
at System.Xml.XmlTextReaderImpl.ParseElementContent()
at System.Xml.XmlTextReaderImpl.Read()
at System.Xml.XmlTextReader.Read()
at System.Xml.XmlTextReaderImpl.Skip()
at System.Xml.XmlTextReader.Skip()
at System.Configuration.XmlUtil.StrictSkipToNextElement(System.Configuration.ExceptionAction)
at System.Configuration.BaseConfigurationRecord.ScanSectionsRecursive(System.Configuration.XmlUtil, System.String, Boolean, System.String, System.Configuration.OverrideModeSetting, Boolean)
at System.Configuration.BaseConfigurationRecord.ScanSectionsRecursive(System.Configuration.XmlUtil, System.String, Boolean, System.String, System.Configuration.OverrideModeSetting, Boolean)
at System.Configuration.BaseConfigurationRecord.ScanSections(System.Configuration.XmlUtil)
at System.Configuration.BaseConfigurationRecord.InitConfigFromFile()

Exception Info: System.Configuration.ConfigurationErrorsException
at System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean)
at System.Configuration.BaseConfigurationRecord.ThrowIfParseErrors(System.Configuration.ConfigurationSchemaErrors)
at System.Configuration.BaseConfigurationRecord.ThrowIfInitErrors()
at System.Configuration.ClientConfigurationSystem.OnConfigRemoved(System.Object, System.Configuration.Internal.InternalConfigEventArgs)

Exception Info: System.Configuration.ConfigurationErrorsException
at System.Configuration.ClientConfigurationSystem.OnConfigRemoved(System.Object, System.Configuration.Internal.InternalConfigEventArgs)
at System.Configuration.Internal.InternalConfigRoot.OnConfigRemoved(System.Configuration.Internal.InternalConfigEventArgs)
at System.Configuration.Internal.InternalConfigRoot.RemoveConfigImpl(System.String, System.Configuration.BaseConfigurationRecord)
at System.Configuration.BaseConfigurationRecord.GetSectionRecursive(System.String, Boolean, Boolean, Boolean, Boolean, System.Object ByRef, System.Object ByRef)
at System.Configuration.BaseConfigurationRecord.GetSection(System.String)
at System.Configuration.ClientConfigurationSystem.System.Configuration.Internal.IInternalConfigSystem.GetSection(System.String)
at System.Configuration.ConfigurationManager.GetSection(System.String)
at System.Configuration.ClientSettingsStore.ReadSettings(System.String, Boolean)
at System.Configuration.LocalFileSettingsProvider.GetPropertyValues(System.Configuration.SettingsContext, System.Configuration.SettingsPropertyCollection)
at System.Configuration.SettingsBase.GetPropertiesFromProvider(System.Configuration.SettingsProvider)
at System.Configuration.SettingsBase.GetPropertyValueByName(System.String)
at System.Configuration.SettingsBase.get_Item(System.String)
at System.Configuration.ApplicationSettingsBase.GetPropertyValue(System.String)
at System.Configuration.ApplicationSettingsBase.get_Item(System.String)
at NovfacUI.Properties.DisplaySettings.get_PalePopupBackgroundColour()
at e.a(System.String[])

0
thenovelfactory

Avatar / Picture

Moderator
Registered:
Posts: 270
Reply with quote  #6 
Hi there,
Sorry to hear you're having problems with the software, can you let me know if you if you've tried the following:

1. uninstalling and reinstalling
2. Creating a new windows user account

Can you let me know if either of those help?

__________________
http://www.novel-software.com
“It's extremely useful in organizing and making me think about what I write. The advice was invaluable, and the step-by-step instructions guided me extremely well through the writing process, allowing me to develop characters and plot a lot further than expected.” - See more at: http://www.novel-software.com/writingsoftwaretestimonials.aspx#sthash.0smYiFBM.dpuf
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.